summaryrefslogtreecommitdiffstats
path: root/third_party/rust/arrayvec/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/arrayvec/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/arrayvec/Cargo.toml')
-rw-r--r--third_party/rust/arrayvec/Cargo.toml62
1 files changed, 62 insertions, 0 deletions
diff --git a/third_party/rust/arrayvec/Cargo.toml b/third_party/rust/arrayvec/Cargo.toml
new file mode 100644
index 0000000000..2a42a3f89b
--- /dev/null
+++ b/third_party/rust/arrayvec/Cargo.toml
@@ -0,0 +1,62 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "arrayvec"
+version = "0.5.1"
+authors = ["bluss"]
+description = "A vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString."
+documentation = "https://docs.rs/arrayvec/"
+keywords = ["stack", "vector", "array", "data-structure", "no_std"]
+categories = ["data-structures", "no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/bluss/arrayvec"
+[package.metadata.docs.rs]
+features = ["serde"]
+
+[package.metadata.release]
+no-dev-version = true
+tag-name = "{{version}}"
+[profile.bench]
+debug = true
+
+[profile.release]
+debug = true
+
+[[bench]]
+name = "extend"
+harness = false
+
+[[bench]]
+name = "arraystring"
+harness = false
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+[dev-dependencies.bencher]
+version = "0.1.4"
+
+[dev-dependencies.matches]
+version = "0.1"
+
+[dev-dependencies.serde_test]
+version = "1.0"
+
+[build-dependencies]
+
+[features]
+array-sizes-129-255 = []
+array-sizes-33-128 = []
+default = ["std"]
+std = []