summaryrefslogtreecommitdiffstats
path: root/third_party/rust/chardetng/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/chardetng/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/chardetng/Cargo.toml')
-rw-r--r--third_party/rust/chardetng/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/third_party/rust/chardetng/Cargo.toml b/third_party/rust/chardetng/Cargo.toml
new file mode 100644
index 0000000000..cca31de9f8
--- /dev/null
+++ b/third_party/rust/chardetng/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "chardetng"
+description = "A character encoding detector for legacy Web content"
+version = "0.1.9"
+authors = ["Henri Sivonen <hsivonen@hsivonen.fi>"]
+edition = "2018"
+license = "Apache-2.0 OR MIT"
+readme = "README.md"
+documentation = "https://docs.rs/chardetng/"
+homepage = "https://docs.rs/chardetng/"
+repository = "https://github.com/hsivonen/chardetng"
+keywords = ["encoding", "web", "unicode", "charset"]
+categories = ["text-processing", "encoding", "web-programming", "internationalization"]
+
+[dependencies]
+encoding_rs = "0.8.17"
+memchr = "2.2.0"
+
+[dev-dependencies]
+detone = "1.0.0"
+
+[features]
+testing-only-no-semver-guarantees-do-not-use = [] \ No newline at end of file