summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crossbeam-deque-0.7.2/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/crossbeam-deque-0.7.2/README.md
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/crossbeam-deque-0.7.2/README.md')
-rw-r--r--third_party/rust/crossbeam-deque-0.7.2/README.md50
1 files changed, 50 insertions, 0 deletions
diff --git a/third_party/rust/crossbeam-deque-0.7.2/README.md b/third_party/rust/crossbeam-deque-0.7.2/README.md
new file mode 100644
index 0000000000..a5ef93a929
--- /dev/null
+++ b/third_party/rust/crossbeam-deque-0.7.2/README.md
@@ -0,0 +1,50 @@
+# Crossbeam Deque
+
+[![Build Status](https://travis-ci.org/crossbeam-rs/crossbeam.svg?branch=master)](
+https://travis-ci.org/crossbeam-rs/crossbeam)
+[![License](https://img.shields.io/badge/license-MIT%2FApache--2.0-blue.svg)](
+https://github.com/crossbeam-rs/crossbeam-deque)
+[![Cargo](https://img.shields.io/crates/v/crossbeam-deque.svg)](
+https://crates.io/crates/crossbeam-deque)
+[![Documentation](https://docs.rs/crossbeam-deque/badge.svg)](
+https://docs.rs/crossbeam-deque)
+[![Rust 1.28+](https://img.shields.io/badge/rust-1.28+-lightgray.svg)](
+https://www.rust-lang.org)
+[![chat](https://img.shields.io/discord/569610676205781012.svg?logo=discord)](https://discord.gg/BBYwKq)
+
+This crate provides work-stealing deques, which are primarily intended for
+building task schedulers.
+
+## Usage
+
+Add this to your `Cargo.toml`:
+
+```toml
+[dependencies]
+crossbeam-deque = "0.7"
+```
+
+Next, add this to your crate:
+
+```rust
+extern crate crossbeam_deque;
+```
+
+## Compatibility
+
+The minimum supported Rust version is 1.28. Any change to this is considered a breaking change.
+
+## License
+
+Licensed under either of
+
+ * Apache License, Version 2.0 ([LICENSE-APACHE](LICENSE-APACHE) or http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+#### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in the work by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.