summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cubeb-pulse/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/cubeb-pulse/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cubeb-pulse/Cargo.toml')
-rw-r--r--third_party/rust/cubeb-pulse/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/third_party/rust/cubeb-pulse/Cargo.toml b/third_party/rust/cubeb-pulse/Cargo.toml
new file mode 100644
index 0000000000..5f245604cc
--- /dev/null
+++ b/third_party/rust/cubeb-pulse/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "cubeb-pulse"
+version = "0.3.0"
+authors = ["Dan Glastonbury <dglastonbury@mozilla.com>"]
+description = "Cubeb backed for PulseAudio written in Rust"
+license = "ISC"
+
+[features]
+pulse-dlopen = ["pulse-ffi/dlopen"]
+
+[lib]
+crate-type = ["staticlib", "rlib"]
+
+[dependencies]
+cubeb-backend = "0.8"
+pulse-ffi = { path = "pulse-ffi" }
+pulse = { path = "pulse-rs" }
+semver = "^0.9"
+ringbuf = "0.2"