summaryrefslogtreecommitdiffstats
path: root/third_party/rust/either/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/either/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/either/Cargo.toml')
-rw-r--r--third_party/rust/either/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/third_party/rust/either/Cargo.toml b/third_party/rust/either/Cargo.toml
new file mode 100644
index 0000000000..1265ea333a
--- /dev/null
+++ b/third_party/rust/either/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "either"
+version = "1.1.0"
+authors = ["bluss"]
+
+license = "MIT/Apache-2.0"
+repository = "https://github.com/bluss/either"
+documentation = "https://docs.rs/either/1/"
+
+description = """
+The enum `Either`, with variants `Left` and `Right` and trait implementations including Iterator, Read, Write.
+
+Either has methods that are similar to Option and Result.
+
+Includes convenience macros `try_left!()` and `try_right!()` to use for short-circuiting logic."""
+
+keywords = ["data-structure", "no_std"]
+categories = ["data-structures", "no-std"]
+
+[features]
+default = ["use_std"]
+use_std = []