summaryrefslogtreecommitdiffstats
path: root/third_party/rust/fxa-client/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/fxa-client/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/fxa-client/Cargo.toml')
-rw-r--r--third_party/rust/fxa-client/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/fxa-client/Cargo.toml b/third_party/rust/fxa-client/Cargo.toml
new file mode 100644
index 0000000000..a7d4e60f1b
--- /dev/null
+++ b/third_party/rust/fxa-client/Cargo.toml
@@ -0,0 +1,39 @@
+[package]
+name = "fxa-client"
+edition = "2018"
+version = "0.1.0"
+authors = ["Edouard Oger <eoger@fastmail.com>"]
+license = "MPL-2.0"
+exclude = ["/android", "/ios"]
+
+[dependencies]
+base64 = "0.12"
+hex = "0.4"
+lazy_static = "1.4"
+log = "0.4"
+prost = "0.6"
+prost-derive = "0.6"
+rand_rccrypto = { path = "../support/rand_rccrypto" }
+serde = { version = "1", features = ["rc"] }
+serde_derive = "1"
+serde_json = "1"
+sync15 = { path = "../sync15" }
+url = "2.1"
+ffi-support = "0.4"
+viaduct = { path = "../viaduct" }
+jwcrypto = { path = "../support/jwcrypto" }
+rc_crypto = { path = "../support/rc_crypto", features = ["ece", "hawk"] }
+error-support = { path = "../support/error" }
+thiserror = "1.0"
+anyhow = "1.0"
+sync-guid = { path = "../support/guid", features = ["random"] }
+
+[dev-dependencies]
+viaduct-reqwest = { path = "../support/viaduct-reqwest" }
+mockiato = "0.9"
+mockito = "0.27"
+
+[features]
+default = []
+gecko = [ "rc_crypto/gecko" ]
+integration_test = []