summaryrefslogtreecommitdiffstats
path: root/third_party/rust/goblin/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/goblin/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/goblin/Cargo.toml')
-rw-r--r--third_party/rust/goblin/Cargo.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/third_party/rust/goblin/Cargo.toml b/third_party/rust/goblin/Cargo.toml
new file mode 100644
index 0000000000..6a7a88b30b
--- /dev/null
+++ b/third_party/rust/goblin/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "goblin"
+version = "0.1.2"
+authors = ["m4b <m4b.github.io@gmail.com>", "seu <seu@panopticon.re>", "Will Glynn <will@willglynn.com>", "Philip Craig <philipjcraig@gmail.com>"]
+include = ["src/**/*", "Cargo.toml", "CHANGELOG.md", "LICENSE", "README.md", "etc/*", "examples/*", "tests/*", "fuzz/**/*"]
+description = "An impish, cross-platform, ELF, Mach-o, and PE binary parsing and loading crate"
+documentation = "https://docs.rs/goblin"
+readme = "README.md"
+keywords = ["binary", "elf", "mach", "pe", "archive"]
+categories = ["parsing", "development-tools::debugging"]
+license = "MIT"
+repository = "https://github.com/m4b/goblin"
+[dependencies.log]
+version = "0.4"
+optional = true
+default-features = false
+
+[dependencies.plain]
+version = "0.2.3"
+
+[dependencies.scroll]
+version = "0.10"
+default_features = false
+
+[features]
+alloc = ["scroll/derive", "log"]
+archive = ["alloc"]
+default = ["std", "elf32", "elf64", "mach32", "mach64", "pe32", "pe64", "archive", "endian_fd"]
+elf32 = []
+elf64 = []
+endian_fd = ["alloc"]
+mach32 = ["alloc", "endian_fd"]
+mach64 = ["alloc", "endian_fd"]
+pe32 = ["alloc", "endian_fd"]
+pe64 = ["alloc", "endian_fd"]
+std = ["alloc", "scroll/std"]
+[badges.travis-ci]
+branch = "master"
+repository = "m4b/goblin"