summaryrefslogtreecommitdiffstats
path: root/third_party/rust/image/Cargo.toml.public-private-dependencies
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/image/Cargo.toml.public-private-dependencies
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/image/Cargo.toml.public-private-dependencies')
-rw-r--r--third_party/rust/image/Cargo.toml.public-private-dependencies58
1 files changed, 58 insertions, 0 deletions
diff --git a/third_party/rust/image/Cargo.toml.public-private-dependencies b/third_party/rust/image/Cargo.toml.public-private-dependencies
new file mode 100644
index 0000000000..3d0a4462c7
--- /dev/null
+++ b/third_party/rust/image/Cargo.toml.public-private-dependencies
@@ -0,0 +1,58 @@
+cargo-features = ["public-dependency"]
+
+[package]
+name = "image"
+version = "0.23.0-preview.0"
+edition = "2018"
+license = "MIT"
+description = "Imaging library written in Rust. Provides basic filters and decoders for the most common image formats."
+authors = ["The image-rs Developers"]
+readme = "README.md"
+documentation = "https://docs.rs/image"
+repository = "https://github.com/image-rs/image"
+homepage = "https://github.com/image-rs/image"
+categories = ["multimedia::images", "multimedia::encoding"]
+exclude = [
+ "src/png/testdata/*",
+ "examples/*",
+ "tests/*",
+]
+
+[lib]
+name = "image"
+path = "./src/lib.rs"
+
+[dependencies]
+# Not yet public.
+bytemuck = "1"
+byteorder = "1.3.2"
+num-iter = "0.1.32"
+num-rational = "0.2.1"
+# Public due to Pixel, otherwise quite useless.
+num-traits = { version = "0.2.0", public = true }
+gif = { version = "0.10.0", optional = true }
+jpeg = { package = "jpeg-decoder", version = "0.1", default-features = false, optional = true }
+png = { version = "0.15.2", optional = true }
+scoped_threadpool = { version = "0.1", optional = true }
+tiff = { version = "0.4.0", optional = true }
+
+[dev-dependencies]
+crc32fast = "1.2.0"
+num-complex = "0.2.0"
+glob = "0.3"
+quickcheck = "0.9"
+
+[features]
+default = ["gif", "jpeg", "ico", "png", "pnm", "tga", "tiff", "webp", "bmp", "hdr", "dxt", "dds", "jpeg_rayon"]
+
+ico = ["bmp", "png"]
+pnm = []
+tga = []
+webp = []
+bmp = []
+hdr = ["scoped_threadpool"]
+dxt = []
+dds = ["dxt"]
+jpeg_rayon = ["jpeg/rayon"]
+
+benchmarks = []