summaryrefslogtreecommitdiffstats
path: root/third_party/rust/intl-memoizer/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/intl-memoizer/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/intl-memoizer/Cargo.toml')
-rw-r--r--third_party/rust/intl-memoizer/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/third_party/rust/intl-memoizer/Cargo.toml b/third_party/rust/intl-memoizer/Cargo.toml
new file mode 100644
index 0000000000..707bec3ecd
--- /dev/null
+++ b/third_party/rust/intl-memoizer/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "intl-memoizer"
+version = "0.5.0"
+authors = ["Zibi Braniecki <gandalf@mozilla.com>", "Manish Goregaokar <manishsmail@gmail.com>"]
+include = ["src/**/*", "benches/*.rs", "Cargo.toml", "README.md"]
+description = "A memoizer specifically tailored for storing lazy-initialized\nintl formatters.\n"
+homepage = "http://www.projectfluent.org"
+readme = "README.md"
+keywords = ["localization", "l10n", "i18n", "intl", "internationalization"]
+categories = ["localization", "internationalization"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/projectfluent/fluent-rs"
+[dependencies.type-map]
+version = "0.3"
+
+[dependencies.unic-langid]
+version = "0.9"
+[dev-dependencies.fluent-langneg]
+version = "0.13"
+
+[dev-dependencies.intl_pluralrules]
+version = "7.0"