summaryrefslogtreecommitdiffstats
path: root/third_party/rust/jsparagus-parser/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/jsparagus-parser/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/jsparagus-parser/Cargo.toml')
-rw-r--r--third_party/rust/jsparagus-parser/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/third_party/rust/jsparagus-parser/Cargo.toml b/third_party/rust/jsparagus-parser/Cargo.toml
new file mode 100644
index 0000000000..e659c07e5f
--- /dev/null
+++ b/third_party/rust/jsparagus-parser/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "jsparagus-parser"
+version = "0.1.0"
+authors = ["Jason Orendorff <jason.orendorff@gmail.com>"]
+edition = "2018"
+license = "MIT/Apache-2.0"
+
+[dependencies]
+bumpalo = "3.4.0"
+jsparagus-ast = { path = "../ast" }
+jsparagus-json-log = { path = "../json-log" }
+jsparagus-generated-parser = { path = "../generated_parser" }
+arrayvec = "0.5.1"
+
+[features]
+logging = ["jsparagus-json-log/logging"]
+
+[dev-dependencies]
+criterion = "0.3"
+
+[[bench]]
+name = "parser"
+harness = false
+