summaryrefslogtreecommitdiffstats
path: root/third_party/rust/libsqlite3-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/libsqlite3-sys/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/libsqlite3-sys/Cargo.toml')
-rw-r--r--third_party/rust/libsqlite3-sys/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/third_party/rust/libsqlite3-sys/Cargo.toml b/third_party/rust/libsqlite3-sys/Cargo.toml
new file mode 100644
index 0000000000..3646b74938
--- /dev/null
+++ b/third_party/rust/libsqlite3-sys/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "libsqlite3-sys"
+version = "0.20.1"
+authors = ["The rusqlite developers"]
+build = "build.rs"
+links = "sqlite3"
+description = "Native bindings to the libsqlite3 library"
+keywords = ["sqlite", "sqlcipher", "ffi"]
+categories = ["external-ffi-bindings"]
+license = "MIT"
+repository = "https://github.com/rusqlite/rusqlite"
+[build-dependencies.bindgen]
+version = "0.55"
+features = ["runtime"]
+optional = true
+default-features = false
+
+[build-dependencies.cc]
+version = "1.0"
+optional = true
+
+[build-dependencies.pkg-config]
+version = "0.3"
+optional = true
+
+[features]
+buildtime_bindgen = ["bindgen", "pkg-config", "vcpkg"]
+bundled = ["cc", "bundled_bindings"]
+bundled-windows = ["cc", "bundled_bindings"]
+bundled_bindings = []
+default = ["min_sqlite_version_3_6_8"]
+in_gecko = []
+min_sqlite_version_3_6_23 = ["pkg-config", "vcpkg"]
+min_sqlite_version_3_6_8 = ["pkg-config", "vcpkg"]
+min_sqlite_version_3_7_16 = ["pkg-config", "vcpkg"]
+min_sqlite_version_3_7_7 = ["pkg-config", "vcpkg"]
+preupdate_hook = ["buildtime_bindgen"]
+session = ["preupdate_hook", "buildtime_bindgen"]
+sqlcipher = []
+unlock_notify = []
+wasm32-wasi-vfs = []
+winsqlite3 = ["min_sqlite_version_3_7_16"]
+with-asan = []
+[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
+version = "0.2"
+optional = true