summaryrefslogtreecommitdiffstats
path: root/third_party/rust/nix/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/nix/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/nix/Cargo.toml')
-rw-r--r--third_party/rust/nix/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/nix/Cargo.toml b/third_party/rust/nix/Cargo.toml
new file mode 100644
index 0000000000..64854b3c06
--- /dev/null
+++ b/third_party/rust/nix/Cargo.toml
@@ -0,0 +1,55 @@
+[package]
+name = "nix"
+description = "Rust friendly bindings to *nix APIs"
+version = "0.13.1"
+authors = ["The nix-rust Project Developers"]
+repository = "https://github.com/nix-rust/nix"
+license = "MIT"
+categories = ["os::unix-apis"]
+exclude = [
+ "/.gitignore",
+ "/.travis.yml",
+ "/ci/*",
+ "/Cross.toml",
+ "/RELEASE_PROCEDURE.md",
+ "/bors.toml"
+]
+
+[dependencies]
+libc = "0.2.57"
+bitflags = "1.0"
+cfg-if = "0.1.0"
+void = "1.0.2"
+
+[target.'cfg(target_os = "dragonfly")'.build-dependencies]
+cc = "1"
+
+[dev-dependencies]
+bytes = "0.4.8"
+lazy_static = "1.2"
+rand = "0.5"
+tempfile = "3"
+
+[target.'cfg(target_os = "freebsd")'.dev-dependencies]
+sysctl = "0.1"
+
+[[test]]
+name = "test"
+path = "test/test.rs"
+
+[[test]]
+name = "test-aio-drop"
+path = "test/sys/test_aio_drop.rs"
+
+[[test]]
+name = "test-lio-listio-resubmit"
+path = "test/sys/test_lio_listio_resubmit.rs"
+
+[[test]]
+name = "test-mount"
+path = "test/test_mount.rs"
+harness = false
+
+[[test]]
+name = "test-ptymaster-drop"
+path = "test/test_ptymaster_drop.rs"