summaryrefslogtreecommitdiffstats
path: root/third_party/rust/nss/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/nss/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/nss/Cargo.toml')
-rw-r--r--third_party/rust/nss/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/third_party/rust/nss/Cargo.toml b/third_party/rust/nss/Cargo.toml
new file mode 100644
index 0000000000..0f779232b6
--- /dev/null
+++ b/third_party/rust/nss/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "nss"
+version = "0.1.0"
+authors = ["application-services@mozilla.com"]
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+crate-type = ["lib"]
+
+[dependencies]
+base64 = "0.12"
+thiserror = "1.0"
+error-support = { path = "../../error" }
+nss_sys = { path = "nss_sys" }
+serde = "1"
+serde_derive = "1"
+
+[features]
+default = []
+gecko = ["nss_sys/gecko"]