summaryrefslogtreecommitdiffstats
path: root/third_party/rust/objc/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/objc/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/objc/Cargo.toml')
-rw-r--r--third_party/rust/objc/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/objc/Cargo.toml b/third_party/rust/objc/Cargo.toml
new file mode 100644
index 0000000000..33a3c70183
--- /dev/null
+++ b/third_party/rust/objc/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "objc"
+version = "0.2.6"
+authors = ["Steven Sheldon"]
+exclude = [".gitignore", ".travis.yml", "doc.sh", "travis_install.sh", "travis_test.sh", "tests-ios/**"]
+description = "Objective-C Runtime bindings and wrapper for Rust."
+documentation = "http://ssheldon.github.io/rust-objc/objc/"
+readme = "README.md"
+keywords = ["objective-c", "osx", "ios", "cocoa", "uikit"]
+license = "MIT"
+repository = "http://github.com/SSheldon/rust-objc"
+[dependencies.malloc_buf]
+version = "0.0"
+
+[dependencies.objc_exception]
+version = "0.1"
+optional = true
+
+[features]
+exception = ["objc_exception"]
+verify_message = []