summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ordered-float/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/ordered-float/README.md
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/ordered-float/README.md')
-rw-r--r--third_party/rust/ordered-float/README.md29
1 files changed, 29 insertions, 0 deletions
diff --git a/third_party/rust/ordered-float/README.md b/third_party/rust/ordered-float/README.md
new file mode 100644
index 0000000000..b5e33021bf
--- /dev/null
+++ b/third_party/rust/ordered-float/README.md
@@ -0,0 +1,29 @@
+# Ordered Floats
+
+Provides several wrapper types for Ord and Eq implementations on f64.
+
+## Usage
+
+Use the crates.io repository; add this to your `Cargo.toml` along
+with the rest of your dependencies:
+
+```toml
+[dependencies]
+ordered-float = "1.0"
+```
+
+See the [API documentation](https://docs.rs/ordered-float) for further details.
+
+## no_std
+
+To use `ordered_float` without requiring the Rust standard library, disable
+the default `std` feature:
+
+```toml
+[dependencies]
+ordered-float = { version = "1.0", default-features = false }
+```
+
+## License
+
+MIT