summaryrefslogtreecommitdiffstats
path: root/third_party/rust/plist/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/plist/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/plist/Cargo.toml')
-rw-r--r--third_party/rust/plist/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/third_party/rust/plist/Cargo.toml b/third_party/rust/plist/Cargo.toml
new file mode 100644
index 0000000000..1852e7fa53
--- /dev/null
+++ b/third_party/rust/plist/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "plist"
+version = "0.5.4"
+authors = ["Ed Barnard <eabarnard@gmail.com>"]
+description = "A rusty plist parser. Supports Serde serialization."
+documentation = "https://docs.rs/plist/0.5.4/plist/"
+keywords = ["plist", "parser"]
+categories = ["config", "encoding", "parser-implementations"]
+license = "MIT"
+repository = "https://github.com/ebarnard/rust-plist/"
+[dependencies.base64]
+version = "0.10.1"
+
+[dependencies.humantime]
+version = "2.0.0"
+
+[dependencies.indexmap]
+version = "1.0.2"
+
+[dependencies.line-wrap]
+version = "0.1.1"
+
+[dependencies.serde]
+version = "1.0.2"
+optional = true
+
+[dependencies.xml_rs]
+version = "0.8.0"
+package = "xml-rs"
+[dev-dependencies.serde_derive]
+version = "1.0.2"
+
+[features]
+default = ["serde"]
+enable_unstable_features_that_may_break_with_minor_version_bumps = []