summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rand_rccrypto/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/rand_rccrypto/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/rand_rccrypto/Cargo.toml')
-rw-r--r--third_party/rust/rand_rccrypto/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/third_party/rust/rand_rccrypto/Cargo.toml b/third_party/rust/rand_rccrypto/Cargo.toml
new file mode 100644
index 0000000000..100f140bf8
--- /dev/null
+++ b/third_party/rust/rand_rccrypto/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "rand_rccrypto"
+version = "0.1.0"
+authors = ["Edouard Oger <eoger@fastmail.com>"]
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+crate-type = ["lib"]
+
+[dependencies]
+rc_crypto = { path = "../rc_crypto" }
+# We do not need the rand default features as we provide
+# our own Rng implementation backed by rc_crypto.
+rand = { version = "0.7", default-features = false, features = ["std"] }
+rand_core = "0.5"