summaryrefslogtreecommitdiffstats
path: root/third_party/rust/raw-cpuid/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/raw-cpuid/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/raw-cpuid/Cargo.toml')
-rw-r--r--third_party/rust/raw-cpuid/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/raw-cpuid/Cargo.toml b/third_party/rust/raw-cpuid/Cargo.toml
new file mode 100644
index 0000000000..58c95d7757
--- /dev/null
+++ b/third_party/rust/raw-cpuid/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "raw-cpuid"
+version = "7.0.3"
+authors = ["Gerd Zellweger <mail@gerdzellweger.com>"]
+build = "build.rs"
+description = "A library to parse the x86 CPUID instruction, written in rust with no external dependencies. The implementation closely resembles the Intel CPUID manual description. The library does only depend on libcore."
+homepage = "https://github.com/gz/rust-cpuid"
+documentation = "https://docs.rs/raw-cpuid/"
+readme = "README.md"
+keywords = ["cpuid", "x86", "amd64", "os", "libcore"]
+license = "MIT"
+repository = "https://github.com/gz/rust-cpuid"
+
+[[bin]]
+name = "cpuid"
+path = "src/bin/cpuid.rs"
+[dependencies.bitflags]
+version = "1.1"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.serde_derive]
+version = "1.0"
+optional = true
+[build-dependencies.cc]
+version = "1"
+
+[build-dependencies.rustc_version]
+version = "0.2"
+
+[features]
+nightly = []
+serialize = ["serde", "serde_derive"]
+use_arch = []
+[target."cfg(unix)".dev-dependencies.core_affinity]
+version = "0.5.9"
+
+[target."cfg(unix)".dev-dependencies.libc]
+version = "0.2"
+default-features = false