summaryrefslogtreecommitdiffstats
path: root/third_party/rust/regalloc/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/regalloc/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/regalloc/Cargo.toml')
-rw-r--r--third_party/rust/regalloc/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/third_party/rust/regalloc/Cargo.toml b/third_party/rust/regalloc/Cargo.toml
new file mode 100644
index 0000000000..7366812c25
--- /dev/null
+++ b/third_party/rust/regalloc/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "regalloc"
+version = "0.0.31"
+authors = ["The Regalloc.rs Developers"]
+edition = "2018"
+license = "Apache-2.0 WITH LLVM-exception"
+description = "Modular register allocation algorithms"
+repository = "https://github.com/bytecodealliance/regalloc.rs"
+
+[dependencies]
+rustc-hash = "1.0.1"
+log = { version = "0.4.8", default-features = false }
+smallvec = "1.0.0"
+serde = { version = "1.0.94", features = ["derive"], optional = true }
+
+[features]
+default = []
+fuzzing = []
+
+# For dependent crates that want to serialize some parts of regalloc.
+enable-serde = ["serde"]