summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rkv/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/rkv/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/rkv/Cargo.toml')
-rw-r--r--third_party/rust/rkv/Cargo.toml88
1 files changed, 88 insertions, 0 deletions
diff --git a/third_party/rust/rkv/Cargo.toml b/third_party/rust/rkv/Cargo.toml
new file mode 100644
index 0000000000..7ad63d705c
--- /dev/null
+++ b/third_party/rust/rkv/Cargo.toml
@@ -0,0 +1,88 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "rkv"
+version = "0.16.1"
+authors = ["Richard Newman <rnewman@twinql.com>", "Nan Jiang <najiang@mozilla.com>", "Myk Melez <myk@mykzilla.org>", "Victor Porof <vporof@mozilla.com>"]
+exclude = ["/tests/envs/*"]
+description = "A simple, humane, typed key-value storage solution"
+homepage = "https://github.com/mozilla/rkv"
+documentation = "https://docs.rs/rkv"
+readme = "README.md"
+keywords = ["lmdb", "database", "storage"]
+categories = ["database"]
+license = "Apache-2.0"
+repository = "https://github.com/mozilla/rkv"
+[dependencies.arrayref]
+version = "0.3"
+
+[dependencies.bincode]
+version = "1.0"
+
+[dependencies.bitflags]
+version = "1"
+
+[dependencies.byteorder]
+version = "1"
+
+[dependencies.failure]
+version = "0.1"
+features = ["derive"]
+default_features = false
+
+[dependencies.id-arena]
+version = "2.2"
+
+[dependencies.lazy_static]
+version = "1.0"
+
+[dependencies.lmdb-rkv]
+version = "0.14"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.ordered-float]
+version = "1.0"
+
+[dependencies.paste]
+version = "0.1"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive", "rc"]
+
+[dependencies.serde_derive]
+version = "1.0"
+
+[dependencies.url]
+version = "2.0"
+
+[dependencies.uuid]
+version = "0.8"
+[dev-dependencies.byteorder]
+version = "1"
+
+[dev-dependencies.tempfile]
+version = "3"
+
+[features]
+backtrace = ["failure/backtrace", "failure/std"]
+db-dup-sort = []
+db-int-key = []
+default = ["db-dup-sort", "db-int-key"]
+no-canonicalize-path = []
+with-asan = ["lmdb-rkv/with-asan"]
+with-fuzzer = ["lmdb-rkv/with-fuzzer"]
+with-fuzzer-no-link = ["lmdb-rkv/with-fuzzer-no-link"]