summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rusqlite/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/rusqlite/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/rusqlite/Cargo.toml')
-rw-r--r--third_party/rust/rusqlite/Cargo.toml169
1 files changed, 169 insertions, 0 deletions
diff --git a/third_party/rust/rusqlite/Cargo.toml b/third_party/rust/rusqlite/Cargo.toml
new file mode 100644
index 0000000000..8efebabd61
--- /dev/null
+++ b/third_party/rust/rusqlite/Cargo.toml
@@ -0,0 +1,169 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "rusqlite"
+version = "0.24.2"
+authors = ["The rusqlite developers"]
+description = "Ergonomic wrapper for SQLite"
+documentation = "http://docs.rs/rusqlite/"
+readme = "README.md"
+keywords = ["sqlite", "database", "ffi"]
+categories = ["database"]
+license = "MIT"
+repository = "https://github.com/rusqlite/rusqlite"
+[package.metadata.docs.rs]
+all-features = false
+default-target = "x86_64-unknown-linux-gnu"
+features = ["array", "backup", "blob", "chrono", "collation", "functions", "limits", "load_extension", "serde_json", "time", "trace", "url", "vtab", "window", "modern_sqlite", "column_decltype"]
+no-default-features = true
+
+[package.metadata.playground]
+all-features = false
+features = ["bundled-full"]
+
+[lib]
+name = "rusqlite"
+
+[[test]]
+name = "config_log"
+harness = false
+
+[[test]]
+name = "deny_single_threaded_sqlite_config"
+
+[[test]]
+name = "vtab"
+
+[[bench]]
+name = "cache"
+harness = false
+
+[[bench]]
+name = "exec"
+harness = false
+[dependencies.bitflags]
+version = "1.2"
+
+[dependencies.byteorder]
+version = "1.3"
+features = ["i128"]
+optional = true
+
+[dependencies.chrono]
+version = "0.4"
+optional = true
+
+[dependencies.csv]
+version = "1.1"
+optional = true
+
+[dependencies.fallible-iterator]
+version = "0.2"
+
+[dependencies.fallible-streaming-iterator]
+version = "0.1"
+
+[dependencies.hashlink]
+version = "0.6"
+
+[dependencies.lazy_static]
+version = "1.4"
+optional = true
+
+[dependencies.libsqlite3-sys]
+version = "0.20.1"
+
+[dependencies.memchr]
+version = "2.3"
+
+[dependencies.serde_json]
+version = "1.0"
+optional = true
+
+[dependencies.smallvec]
+version = "1.0"
+
+[dependencies.time]
+version = "0.2"
+optional = true
+
+[dependencies.url]
+version = "2.1"
+optional = true
+
+[dependencies.uuid]
+version = "0.8"
+optional = true
+[dev-dependencies.bencher]
+version = "0.1"
+
+[dev-dependencies.doc-comment]
+version = "0.3"
+
+[dev-dependencies.lazy_static]
+version = "1.4"
+
+[dev-dependencies.regex]
+version = "1.3"
+
+[dev-dependencies.tempfile]
+version = "3.1.0"
+
+[dev-dependencies.unicase]
+version = "2.6.0"
+
+[dev-dependencies.uuid]
+version = "0.8"
+features = ["v4"]
+
+[features]
+array = ["vtab"]
+backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
+blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
+buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"]
+bundled = ["libsqlite3-sys/bundled", "modern_sqlite"]
+bundled-full = ["array", "backup", "blob", "bundled", "chrono", "collation", "column_decltype", "csvtab", "extra_check", "functions", "hooks", "i128_blob", "limits", "load_extension", "serde_json", "series", "trace", "unlock_notify", "url", "uuid", "vtab", "window"]
+bundled-windows = ["libsqlite3-sys/bundled-windows"]
+collation = []
+column_decltype = []
+csvtab = ["csv", "vtab"]
+extra_check = []
+functions = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
+hooks = []
+i128_blob = ["byteorder"]
+in_gecko = ["modern_sqlite", "libsqlite3-sys/in_gecko"]
+limits = []
+load_extension = []
+modern_sqlite = ["libsqlite3-sys/bundled_bindings"]
+series = ["vtab"]
+session = ["libsqlite3-sys/session", "hooks"]
+sqlcipher = ["libsqlite3-sys/sqlcipher"]
+trace = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
+unlock_notify = ["libsqlite3-sys/unlock_notify"]
+vtab = ["libsqlite3-sys/min_sqlite_version_3_7_7", "lazy_static"]
+wasm32-wasi-vfs = ["libsqlite3-sys/wasm32-wasi-vfs"]
+window = ["functions"]
+winsqlite3 = ["libsqlite3-sys/winsqlite3"]
+with-asan = ["libsqlite3-sys/with-asan"]
+[badges.appveyor]
+repository = "rusqlite/rusqlite"
+
+[badges.codecov]
+repository = "rusqlite/rusqlite"
+
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+repository = "rusqlite/rusqlite"