summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rust_decimal/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/rust_decimal/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/rust_decimal/Cargo.toml')
-rw-r--r--third_party/rust/rust_decimal/Cargo.toml82
1 files changed, 82 insertions, 0 deletions
diff --git a/third_party/rust/rust_decimal/Cargo.toml b/third_party/rust/rust_decimal/Cargo.toml
new file mode 100644
index 0000000000..23c99a12f4
--- /dev/null
+++ b/third_party/rust/rust_decimal/Cargo.toml
@@ -0,0 +1,82 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "rust_decimal"
+version = "1.7.0"
+authors = ["Paul Mason <paul@form1.co.nz>"]
+description = "A Decimal Implementation written in pure Rust suitable for financial calculations."
+documentation = "https://docs.rs/rust_decimal/"
+readme = "./README.md"
+keywords = ["decimal", "financial", "fixed", "precision"]
+categories = ["science", "data-structures"]
+license = "MIT"
+repository = "https://github.com/paupino/rust-decimal"
+[dependencies.byteorder]
+version = "1.3"
+optional = true
+
+[dependencies.bytes]
+version = "0.5"
+optional = true
+
+[dependencies.diesel]
+version = "1.4"
+features = ["postgres"]
+optional = true
+default-features = false
+
+[dependencies.num-traits]
+version = "0.2"
+
+[dependencies.postgres]
+version = "0.17"
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dependencies.tokio-postgres]
+version = "0.5"
+optional = true
+[dev-dependencies.bincode]
+version = "1.3"
+
+[dev-dependencies.bytes]
+version = "0.5"
+
+[dev-dependencies.futures]
+version = "0.3"
+
+[dev-dependencies.rand]
+version = "0.7"
+
+[dev-dependencies.serde_derive]
+version = "1.0"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.tokio]
+version = "0.2"
+features = ["rt-threaded", "test-util", "macros"]
+
+[features]
+db-diesel-postgres = ["diesel"]
+db-postgres = ["postgres", "bytes", "byteorder"]
+db-tokio-postgres = ["postgres", "tokio-postgres", "bytes", "byteorder"]
+default = ["serde"]
+serde-bincode = ["serde"]
+serde-float = ["serde"]
+tokio-pg = ["db-tokio-postgres"]