summaryrefslogtreecommitdiffstats
path: root/third_party/rust/sha-1/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/sha-1/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/sha-1/Cargo.toml')
-rw-r--r--third_party/rust/sha-1/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/third_party/rust/sha-1/Cargo.toml b/third_party/rust/sha-1/Cargo.toml
new file mode 100644
index 0000000000..ccdeb9aee8
--- /dev/null
+++ b/third_party/rust/sha-1/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "sha-1"
+version = "0.8.1"
+authors = ["RustCrypto Developers"]
+description = "SHA-1 hash function"
+documentation = "https://docs.rs/sha-1"
+keywords = ["crypto", "sha1", "hash", "digest"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/hashes"
+
+[lib]
+name = "sha1"
+[dependencies.block-buffer]
+version = "0.7"
+
+[dependencies.digest]
+version = "0.8"
+
+[dependencies.fake-simd]
+version = "0.1"
+
+[dependencies.opaque-debug]
+version = "0.2"
+
+[dependencies.sha1-asm]
+version = "0.4"
+optional = true
+[dev-dependencies.digest]
+version = "0.8"
+features = ["dev"]
+
+[dev-dependencies.hex-literal]
+version = "0.1"
+
+[features]
+asm = ["sha1-asm"]
+default = ["std"]
+std = ["digest/std"]
+[badges.travis-ci]
+repository = "RustCrypto/hashes"