summaryrefslogtreecommitdiffstats
path: root/third_party/rust/socket2/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/socket2/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/socket2/Cargo.toml')
-rw-r--r--third_party/rust/socket2/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/third_party/rust/socket2/Cargo.toml b/third_party/rust/socket2/Cargo.toml
new file mode 100644
index 0000000000..41be0c3093
--- /dev/null
+++ b/third_party/rust/socket2/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "socket2"
+version = "0.3.10"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+description = "Utilities for handling networking sockets with a maximal amount of configuration\npossible intended.\n"
+homepage = "https://github.com/alexcrichton/socket2-rs"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/alexcrichton/socket2-rs"
+[package.metadata.docs.rs]
+all-features = true
+[dev-dependencies.tempdir]
+version = "0.3"
+
+[features]
+pair = []
+reuseport = []
+unix = []
+[target."cfg(any(unix, target_os = \"redox\"))".dependencies.cfg-if]
+version = "0.1"
+
+[target."cfg(any(unix, target_os = \"redox\"))".dependencies.libc]
+version = "0.2.42"
+[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
+version = "0.1.38"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.3"
+features = ["handleapi", "ws2def", "ws2ipdef", "ws2tcpip", "minwindef"]