summaryrefslogtreecommitdiffstats
path: root/third_party/rust/strsim/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/strsim/README.md
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/strsim/README.md')
-rw-r--r--third_party/rust/strsim/README.md62
1 files changed, 62 insertions, 0 deletions
diff --git a/third_party/rust/strsim/README.md b/third_party/rust/strsim/README.md
new file mode 100644
index 0000000000..747debbc3b
--- /dev/null
+++ b/third_party/rust/strsim/README.md
@@ -0,0 +1,62 @@
+# strsim-rs [![Crates.io](https://img.shields.io/crates/v/strsim.svg)](https://crates.io/crates/strsim) [![Crates.io](https://img.shields.io/crates/l/strsim.svg?maxAge=2592000)](https://github.com/dguo/strsim-rs/blob/master/LICENSE) [![Linux build status](https://travis-ci.org/dguo/strsim-rs.svg?branch=master)](https://travis-ci.org/dguo/strsim-rs) [![Windows build status](https://ci.appveyor.com/api/projects/status/ggue6i785618a39w?svg=true)](https://ci.appveyor.com/project/dguo/strsim-rs)
+
+[Rust](https://www.rust-lang.org) implementations of [string similarity metrics]:
+ - [Hamming]
+ - [Levenshtein]
+ - [Optimal string alignment]
+ - [Damerau-Levenshtein]
+ - [Jaro and Jaro-Winkler] - this implementation of Jaro-Winkler does not limit the common prefix length
+
+### Installation
+```toml
+# Cargo.toml
+[dependencies]
+strsim = "0.7.0"
+```
+
+### [Documentation](https://docs.rs/strsim/)
+You can change the version in the url to see the documentation for an older
+version in the
+[changelog](https://github.com/dguo/strsim-rs/blob/master/CHANGELOG.md).
+
+### Usage
+```rust
+extern crate strsim;
+
+use strsim::{hamming, levenshtein, osa_distance, damerau_levenshtein, jaro,
+ jaro_winkler};
+
+fn main() {
+ match hamming("hamming", "hammers") {
+ Ok(distance) => assert_eq!(3, distance),
+ Err(why) => panic!("{:?}", why)
+ }
+
+ assert_eq!(3, levenshtein("kitten", "sitting"));
+
+ assert_eq!(3, osa_distance("ac", "cba"));
+
+ assert_eq!(2, damerau_levenshtein("ac", "cba"));
+
+ assert!((0.392 - jaro("Friedrich Nietzsche", "Jean-Paul Sartre")).abs() <
+ 0.001);
+
+ assert!((0.911 - jaro_winkler("cheeseburger", "cheese fries")).abs() <
+ 0.001);
+}
+```
+
+### Development
+If you don't want to install Rust itself, you can run `$ ./dev` for a
+development CLI if you have [Docker] installed.
+
+### License
+[MIT](https://github.com/dguo/strsim-rs/blob/master/LICENSE)
+
+[string similarity metrics]:http://en.wikipedia.org/wiki/String_metric
+[Damerau-Levenshtein]:http://en.wikipedia.org/wiki/Damerau%E2%80%93Levenshtein_distance
+[Jaro and Jaro-Winkler]:http://en.wikipedia.org/wiki/Jaro%E2%80%93Winkler_distance
+[Levenshtein]:http://en.wikipedia.org/wiki/Levenshtein_distance
+[Hamming]:http://en.wikipedia.org/wiki/Hamming_distance
+[Optimal string alignment]:https://en.wikipedia.org/wiki/Damerau%E2%80%93Levenshtein_distance#Optimal_string_alignment_distance
+[Docker]:https://docs.docker.com/engine/installation/