summaryrefslogtreecommitdiffstats
path: root/third_party/rust/sync15/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/sync15/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/sync15/Cargo.toml')
-rw-r--r--third_party/rust/sync15/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/sync15/Cargo.toml b/third_party/rust/sync15/Cargo.toml
new file mode 100644
index 0000000000..66967b2101
--- /dev/null
+++ b/third_party/rust/sync15/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "sync15"
+edition = "2018"
+version = "0.1.0"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+license = "MPL-2.0"
+exclude = ["/android", "/ios"]
+
+[features]
+default = []
+
+[dependencies]
+base64 = "0.12"
+ffi-support = "0.4"
+serde = "1"
+serde_derive = "1"
+serde_json = "1"
+url = "2.1"
+log = "0.4"
+lazy_static = "1.4"
+base16 = "0.2"
+rc_crypto = { path = "../support/rc_crypto", features = ["hawk"] }
+viaduct = { path = "../viaduct" }
+interrupt-support = { path = "../support/interrupt" }
+error-support = { path = "../support/error" }
+sync-guid = { path = "../support/guid", features = ["random"] }
+sync15-traits = {path = "../support/sync15-traits"}
+thiserror = "1.0"
+anyhow = "1.0"
+
+[dev-dependencies]
+env_logger = { version = "0.7", default-features = false }