summaryrefslogtreecommitdiffstats
path: root/third_party/rust/term_size/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/term_size/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/term_size/Cargo.toml')
-rw-r--r--third_party/rust/term_size/Cargo.toml68
1 files changed, 68 insertions, 0 deletions
diff --git a/third_party/rust/term_size/Cargo.toml b/third_party/rust/term_size/Cargo.toml
new file mode 100644
index 0000000000..56201428ab
--- /dev/null
+++ b/third_party/rust/term_size/Cargo.toml
@@ -0,0 +1,68 @@
+[package]
+name = "term_size"
+version = "0.3.0"
+authors = ["Kevin K. <kbknapp@gmail.com>", "Benjamin Sago <ogham@bsago.me>"]
+exclude = []
+description = "functions for determining terminal sizes and dimensions"
+repository = "https://github.com/kbknapp/term_size-rs.git"
+documentation = "https://kbknapp.github.io/term_size-rs"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+keywords = ["term", "terminal", "size", "width", "dimension"]
+
+[dependencies]
+clippy = { version = "~0.0.112", optional = true }
+
+[target.'cfg(not(target_os = "windows"))'.dependencies]
+libc = "~0.2.20"
+
+[target.'cfg(target_os = "windows")'.dependencies]
+kernel32-sys = "~0.2.2"
+winapi = "~0.2.8"
+
+[features]
+default = []
+lints = ["clippy", "nightly"]
+nightly = [] # for building with nightly and unstable features
+unstable = [] # for building with unstable features on stable Rust
+debug = [] # for building with debug messages
+travis = ["lints", "nightly"] # for building with travis-cargo
+
+[profile.release]
+opt-level = 3
+debug = false
+rpath = false
+lto = true
+debug-assertions = false
+# codegen-units ignored with lto=true
+
+[profile.dev]
+opt-level = 0
+debug = true
+rpath = false
+lto = false
+debug-assertions = true
+codegen-units = 4
+
+[profile.test]
+opt-level = 1
+debug = true
+rpath = false
+lto = false
+debug-assertions = true
+codegen-units = 2
+
+[profile.bench]
+opt-level = 3
+debug = false
+rpath = false
+lto = true
+debug-assertions = false
+
+[profile.doc]
+opt-level = 0
+debug = true
+rpath = false
+lto = false
+debug-assertions = true
+codegen-units = 4