summaryrefslogtreecommitdiffstats
path: root/third_party/rust/termion/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/termion/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/termion/Cargo.toml')
-rw-r--r--third_party/rust/termion/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/rust/termion/Cargo.toml b/third_party/rust/termion/Cargo.toml
new file mode 100644
index 0000000000..a4415719a8
--- /dev/null
+++ b/third_party/rust/termion/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "termion"
+version = "1.5.1"
+authors = ["ticki <Ticki@users.noreply.github.com>", "gycos <alexandre.bury@gmail.com>", "IGI-111 <igi-111@protonmail.com>"]
+description = "A bindless library for manipulating terminals."
+repository = "https://github.com/ticki/termion"
+documentation = "https://docs.rs/termion"
+license = "MIT"
+keywords = ["tty", "color", "terminal", "password", "tui"]
+exclude = ["target", "CHANGELOG.md", "image.png", "Cargo.lock"]
+
+[target.'cfg(not(target_os = "redox"))'.dependencies]
+libc = "0.2.8"
+
+[target.'cfg(target_os = "redox")'.dependencies]
+redox_syscall = "0.1"
+redox_termios = "0.1"