summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tokio-threadpool/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/tokio-threadpool/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/tokio-threadpool/Cargo.toml')
-rw-r--r--third_party/rust/tokio-threadpool/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/third_party/rust/tokio-threadpool/Cargo.toml b/third_party/rust/tokio-threadpool/Cargo.toml
new file mode 100644
index 0000000000..5541360ec6
--- /dev/null
+++ b/third_party/rust/tokio-threadpool/Cargo.toml
@@ -0,0 +1,61 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "tokio-threadpool"
+version = "0.1.17"
+authors = ["Carl Lerche <me@carllerche.com>"]
+description = "A task scheduler backed by a work-stealing thread pool.\n"
+homepage = "https://github.com/tokio-rs/tokio"
+documentation = "https://docs.rs/tokio-threadpool/0.1.17/tokio_threadpool"
+keywords = ["futures", "tokio"]
+categories = ["concurrency", "asynchronous"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+[dependencies.crossbeam-deque]
+version = "0.7.0"
+
+[dependencies.crossbeam-queue]
+version = "0.1.0"
+
+[dependencies.crossbeam-utils]
+version = "0.6.4"
+
+[dependencies.futures]
+version = "0.1.19"
+
+[dependencies.lazy_static]
+version = "1"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.num_cpus]
+version = "1.2"
+
+[dependencies.slab]
+version = "0.4.1"
+
+[dependencies.tokio-executor]
+version = "0.1.8"
+[dev-dependencies.env_logger]
+version = "0.6"
+default-features = false
+
+[dev-dependencies.futures-cpupool]
+version = "0.1.7"
+
+[dev-dependencies.rand]
+version = "0.7"
+
+[dev-dependencies.threadpool]
+version = "1.7.1"