summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tracing/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/tracing/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/tracing/Cargo.toml')
-rw-r--r--third_party/rust/tracing/Cargo.toml88
1 files changed, 88 insertions, 0 deletions
diff --git a/third_party/rust/tracing/Cargo.toml b/third_party/rust/tracing/Cargo.toml
new file mode 100644
index 0000000000..94b5916458
--- /dev/null
+++ b/third_party/rust/tracing/Cargo.toml
@@ -0,0 +1,88 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "tracing"
+version = "0.1.21"
+authors = ["Eliza Weisman <eliza@buoyant.io>", "Tokio Contributors <team@tokio.rs>"]
+description = "Application-level tracing for Rust.\n"
+homepage = "https://tokio.rs"
+readme = "README.md"
+keywords = ["logging", "tracing", "metrics", "async"]
+categories = ["development-tools::debugging", "development-tools::profiling", "asynchronous", "no-std"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tracing"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[[bench]]
+name = "subscriber"
+harness = false
+
+[[bench]]
+name = "no_subscriber"
+harness = false
+[dependencies.cfg-if]
+version = "0.1.10"
+
+[dependencies.log]
+version = "0.4"
+optional = true
+
+[dependencies.pin-project-lite]
+version = "0.1"
+
+[dependencies.tracing-attributes]
+version = "0.1.10"
+optional = true
+
+[dependencies.tracing-core]
+version = "0.1.17"
+default-features = false
+[dev-dependencies.criterion]
+version = "0.3"
+default_features = false
+
+[dev-dependencies.futures]
+version = "0.1"
+
+[dev-dependencies.log]
+version = "0.4"
+
+[dev-dependencies.tokio]
+version = "0.2.21"
+features = ["rt-core"]
+
+[features]
+async-await = []
+attributes = ["tracing-attributes"]
+default = ["std", "attributes"]
+log-always = ["log"]
+max_level_debug = []
+max_level_error = []
+max_level_info = []
+max_level_off = []
+max_level_trace = []
+max_level_warn = []
+release_max_level_debug = []
+release_max_level_error = []
+release_max_level_info = []
+release_max_level_off = []
+release_max_level_trace = []
+release_max_level_warn = []
+std = ["tracing-core/std"]
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
+version = "^0.3"
+[badges.maintenance]
+status = "actively-developed"