summaryrefslogtreecommitdiffstats
path: root/third_party/rust/unicode-bidi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/unicode-bidi/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/unicode-bidi/Cargo.toml')
-rw-r--r--third_party/rust/unicode-bidi/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/rust/unicode-bidi/Cargo.toml b/third_party/rust/unicode-bidi/Cargo.toml
new file mode 100644
index 0000000000..f12ebcd60b
--- /dev/null
+++ b/third_party/rust/unicode-bidi/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "unicode-bidi"
+version = "0.3.4"
+authors = ["The Servo Project Developers"]
+exclude = ["benches/**", "data/**", "examples/**", "tests/**", "tools/**"]
+description = "Implementation of the Unicode Bidirectional Algorithm"
+documentation = "http://doc.servo.org/unicode_bidi/"
+keywords = ["rtl", "unicode", "text", "layout", "bidi"]
+license = "MIT / Apache-2.0"
+repository = "https://github.com/servo/unicode-bidi"
+
+[lib]
+name = "unicode_bidi"
+[dependencies.flame]
+version = "0.1"
+optional = true
+
+[dependencies.flamer]
+version = "0.1"
+optional = true
+
+[dependencies.serde]
+version = ">=0.8, <2.0"
+features = ["derive"]
+optional = true
+
+[dependencies.matches]
+version = "0.1"
+[dev-dependencies.serde_test]
+version = ">=0.8, <2.0"
+
+[features]
+with_serde = ["serde"]
+flame_it = ["flame", "flamer"]
+unstable = []
+default = []
+bench_it = []