summaryrefslogtreecommitdiffstats
path: root/third_party/rust/webrtc-sdp/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/rust/webrtc-sdp/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/webrtc-sdp/Cargo.toml')
-rw-r--r--third_party/rust/webrtc-sdp/Cargo.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/third_party/rust/webrtc-sdp/Cargo.toml b/third_party/rust/webrtc-sdp/Cargo.toml
new file mode 100644
index 0000000000..1a6d3fc4d5
--- /dev/null
+++ b/third_party/rust/webrtc-sdp/Cargo.toml
@@ -0,0 +1,50 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "webrtc-sdp"
+version = "0.3.8"
+authors = ["Nils Ohlmeier <github@ohlmeier.org>"]
+description = "This create parses strings in the format of the Session Description Protocol according to RFC4566. It specifically supports the subset of features required to support WebRTC according to the JSEP draft."
+readme = "README.md"
+keywords = ["webrtc", "sdp", "jsep"]
+categories = ["parsing", "network-programming"]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/webrtc-sdp"
+[dependencies.log]
+version = "0.4.6"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dependencies.serde_derive]
+version = "1.0"
+optional = true
+
+[dependencies.url]
+version = "2.1.0"
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+default = ["enhanced_debug"]
+enhanced_debug = []
+serialize = ["serde", "serde_derive"]
+[badges.codecov]
+branch = "master"
+repository = "mozilla/webrtc-sdp"
+service = "github"
+
+[badges.travis-ci]
+branch = "master"
+repository = "mozilla/webrtc-sdp"