summaryrefslogtreecommitdiffstats
path: root/js/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'js/rust/Cargo.toml')
-rw-r--r--js/rust/Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/js/rust/Cargo.toml b/js/rust/Cargo.toml
new file mode 100644
index 0000000000..2b4c9f07a7
--- /dev/null
+++ b/js/rust/Cargo.toml
@@ -0,0 +1,54 @@
+[package]
+name = "js"
+version = "0.1.4"
+authors = ["The Servo Project Developers"]
+build = "build.rs"
+license = "MPL-2.0"
+
+[build-dependencies]
+env_logger = {version = "0.8", default-features = false} # disable `regex` to reduce code size
+bindgen = {version = "0.56", default-features = false, features = ["runtime"]} # disable `logging` to reduce code size
+cmake = "0.1"
+glob = "0.3"
+
+[[test]]
+name = "bigint"
+required-features = ["bigint"]
+[[test]]
+name = "callback"
+[[test]]
+name = "enumerate"
+[[test]]
+name = "evaluate"
+[[test]]
+name = "panic"
+[[test]]
+name = "rooting"
+[[test]]
+name = "runtime"
+[[test]]
+name = "typedarray"
+[[test]]
+name = "stack_limit"
+[[test]]
+name = "value"
+[[test]]
+name = "vec_conversion"
+
+[lib]
+doctest = false
+
+[features]
+debugmozjs = ['mozjs_sys/debugmozjs']
+promises = ['mozjs_sys/promises']
+nonzero = []
+bigint = ['mozjs_sys/bigint']
+
+[dependencies.mozjs_sys]
+path = "../src"
+
+[dependencies]
+lazy_static = "1.0"
+libc = "0.2"
+log = "0.4"
+num-traits = "0.2"