summaryrefslogtreecommitdiffstats
path: root/js/src/rust
diff options
context:
space:
mode:
Diffstat (limited to 'js/src/rust')
-rw-r--r--js/src/rust/Cargo.toml24
-rw-r--r--js/src/rust/extra-bindgen-flags.in1
-rw-r--r--js/src/rust/lib.rs20
-rw-r--r--js/src/rust/moz.build40
-rw-r--r--js/src/rust/shared/Cargo.toml28
-rw-r--r--js/src/rust/shared/lib.rs23
-rw-r--r--js/src/rust/wasm.rs91
7 files changed, 227 insertions, 0 deletions
diff --git a/js/src/rust/Cargo.toml b/js/src/rust/Cargo.toml
new file mode 100644
index 0000000000..659967daf8
--- /dev/null
+++ b/js/src/rust/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "jsrust"
+version = "0.1.0"
+authors = ["The Spidermonkey developers"]
+
+[lib]
+name = "jsrust"
+crate-type = ["staticlib"]
+path = "lib.rs"
+
+[features]
+cranelift_x86 = ['jsrust_shared/cranelift_x86']
+cranelift_arm32 = ['jsrust_shared/cranelift_arm32']
+cranelift_arm64 = ['jsrust_shared/cranelift_arm64']
+cranelift_none = ['jsrust_shared/cranelift_none']
+simd-accel = ['jsrust_shared/simd-accel']
+smoosh = ['jsrust_shared/smoosh']
+
+[dependencies]
+jsrust_shared = { path = "./shared" }
+# Workaround for https://github.com/rust-lang/rust/issues/58393
+mozglue-static = { path = "../../../mozglue/static/rust" }
+wat = { version = "1.0.33" }
+wasmparser = { version = "0.48.2" }
diff --git a/js/src/rust/extra-bindgen-flags.in b/js/src/rust/extra-bindgen-flags.in
new file mode 100644
index 0000000000..ddf9e8df49
--- /dev/null
+++ b/js/src/rust/extra-bindgen-flags.in
@@ -0,0 +1 @@
+@BINDGEN_SYSTEM_FLAGS@
diff --git a/js/src/rust/lib.rs b/js/src/rust/lib.rs
new file mode 100644
index 0000000000..e334ba8562
--- /dev/null
+++ b/js/src/rust/lib.rs
@@ -0,0 +1,20 @@
+/* Copyright 2018 Mozilla Foundation
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+extern crate jsrust_shared;
+extern crate wasmparser;
+extern crate wat;
+
+mod wasm;
diff --git a/js/src/rust/moz.build b/js/src/rust/moz.build
new file mode 100644
index 0000000000..44fd84a7de
--- /dev/null
+++ b/js/src/rust/moz.build
@@ -0,0 +1,40 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+features = []
+
+if CONFIG["ENABLE_WASM_CRANELIFT"]:
+ if CONFIG["JS_CODEGEN_X64"] or CONFIG["JS_CODEGEN_X86"]:
+ features += ["cranelift_x86"]
+ elif CONFIG["JS_CODEGEN_ARM"]:
+ features += ["cranelift_arm32"]
+ elif CONFIG["JS_CODEGEN_ARM64"]:
+ features += ["cranelift_arm64"]
+ else:
+ features += ["cranelift_none"]
+
+if CONFIG["MOZ_RUST_SIMD"]:
+ features += ["simd-accel"]
+
+if CONFIG["JS_ENABLE_SMOOSH"]:
+ features += ["smoosh"]
+
+RustLibrary("jsrust", features)
+
+if CONFIG["JS_SHARED_LIBRARY"]:
+ FINAL_LIBRARY = "js"
+
+if CONFIG["OS_ARCH"] == "Darwin":
+ # The Rust standard library references libresolv on macOS, so we need to
+ # link it as a workaround. See also bug 1367932.
+ OS_LIBS += ["-lresolv"]
+elif CONFIG["OS_ARCH"] == "WINNT":
+ # Extra libraries used by Rust bindings libs in debug builds.
+ OS_LIBS += [
+ "shell32",
+ "userenv",
+ "ws2_32",
+ ]
diff --git a/js/src/rust/shared/Cargo.toml b/js/src/rust/shared/Cargo.toml
new file mode 100644
index 0000000000..e80f88d615
--- /dev/null
+++ b/js/src/rust/shared/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "jsrust_shared"
+version = "0.1.0"
+authors = ["The Spidermonkey developers"]
+
+[lib]
+crate-type = ["rlib"]
+name = "jsrust_shared"
+path = "lib.rs"
+
+[dependencies]
+baldrdash = { path = "../../wasm/cranelift", optional = true }
+encoding_c = "0.9.5"
+encoding_c_mem = "0.2.4"
+smoosh = { path = "../../frontend/smoosh", optional = true }
+mozilla-central-workspace-hack = { path = "../../../../build/workspace-hack" }
+mozglue-static = { path = "../../../../mozglue/static/rust" }
+
+[features]
+cranelift_x86 = ['baldrdash/cranelift_x86']
+cranelift_arm32 = ['baldrdash/cranelift_arm32']
+cranelift_arm64 = ['baldrdash/cranelift_arm64']
+cranelift_none = ['baldrdash/cranelift_none']
+simd-accel = ['encoding_c/simd-accel']
+
+# Uncomment this to enable perf support in release mode.
+#[profile.release]
+#debug = true
diff --git a/js/src/rust/shared/lib.rs b/js/src/rust/shared/lib.rs
new file mode 100644
index 0000000000..31a3d5c53a
--- /dev/null
+++ b/js/src/rust/shared/lib.rs
@@ -0,0 +1,23 @@
+/* Copyright 2018 Mozilla Foundation
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+#[cfg(feature = "baldrdash")]
+extern crate baldrdash;
+
+extern crate encoding_c;
+extern crate encoding_c_mem;
+extern crate mozglue_static;
+
+#[cfg(feature = "smoosh")]
+extern crate smoosh;
diff --git a/js/src/rust/wasm.rs b/js/src/rust/wasm.rs
new file mode 100644
index 0000000000..c8230063c0
--- /dev/null
+++ b/js/src/rust/wasm.rs
@@ -0,0 +1,91 @@
+/* Copyright 2020 Mozilla Foundation
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+#[no_mangle]
+pub unsafe extern "C" fn wasm_text_to_binary(
+ text: *const u16,
+ text_len: usize,
+ out_bytes: *mut *mut u8,
+ out_bytes_len: *mut usize,
+ out_error: *mut *mut u8,
+ out_error_len: *mut usize,
+) -> bool {
+ let text_slice = std::slice::from_raw_parts(text, text_len);
+ let text = String::from_utf16_lossy(text_slice);
+ match wat::parse_str(&text) {
+ Ok(bytes) => {
+ let bytes_box = bytes.into_boxed_slice();
+ let bytes_slice = Box::leak(bytes_box);
+ out_bytes.write(bytes_slice.as_mut_ptr());
+ out_bytes_len.write(bytes_slice.len());
+ true
+ }
+ Err(error) => {
+ let error = Box::leak(format!("{}\0", error).into_boxed_str());
+ out_error.write(error.as_mut_ptr());
+ out_error_len.write(error.len());
+ false
+ }
+ }
+}
+
+#[no_mangle]
+pub unsafe extern "C" fn wasm_code_offsets(
+ bytes: *const u8,
+ bytes_len: usize,
+ out_offsets: *mut *mut u32,
+ out_offsets_len: *mut usize,
+) {
+ fn code_offsets(bytes: &[u8]) -> Vec<u32> {
+ use wasmparser::*;
+
+ if bytes.is_empty() {
+ return Vec::new();
+ }
+
+ let mut offsets = Vec::new();
+ let mut parser = Parser::new(bytes);
+ let mut next_input = ParserInput::Default;
+
+ while !parser.eof() {
+ let offset = parser.current_position();
+ match parser.read_with_input(next_input) {
+ ParserState::BeginSection { code, .. } if *code != SectionCode::Code => {
+ next_input = ParserInput::SkipSection;
+ }
+ ParserState::CodeOperator(..) => {
+ offsets.push(offset as u32);
+ next_input = ParserInput::Default
+ }
+ _ => next_input = ParserInput::Default,
+ }
+ }
+
+ offsets
+ }
+
+ let bytes = std::slice::from_raw_parts(bytes, bytes_len);
+ let offsets = code_offsets(bytes);
+
+ if offsets.len() == 0 {
+ out_offsets.write(std::ptr::null_mut());
+ out_offsets_len.write(0);
+ } else {
+ let offsets_box = offsets.into_boxed_slice();
+ let offsets_slice = Box::leak(offsets_box);
+ out_offsets.write(offsets_slice.as_mut_ptr());
+ out_offsets_len.write(offsets_slice.len());
+ }
+}