summaryrefslogtreecommitdiffstats
path: root/testing/geckodriver/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'testing/geckodriver/Cargo.toml')
-rw-r--r--testing/geckodriver/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/geckodriver/Cargo.toml b/testing/geckodriver/Cargo.toml
new file mode 100644
index 0000000000..ee65fe4912
--- /dev/null
+++ b/testing/geckodriver/Cargo.toml
@@ -0,0 +1,34 @@
+[package]
+name = "geckodriver"
+version = "0.29.0"
+description = "Proxy for using WebDriver clients to interact with Gecko-based browsers."
+keywords = ["webdriver", "w3c", "httpd", "mozilla", "firefox"]
+repository = "https://hg.mozilla.org/mozilla-central/file/tip/testing/geckodriver"
+readme = "README.md"
+license = "MPL-2.0"
+publish = false
+edition = "2018"
+
+[dependencies]
+base64 = "0.12"
+chrono = "0.4.6"
+clap = { version = "^2.19", default-features = false, features = ["suggestions", "wrap_help"] }
+hyper = "0.13"
+lazy_static = "1.0"
+log = { version = "0.4", features = ["std"] }
+marionette = { path = "./marionette" }
+mozdevice = { path = "../mozbase/rust/mozdevice" }
+mozprofile = { path = "../mozbase/rust/mozprofile" }
+mozrunner = { path = "../mozbase/rust/mozrunner" }
+mozversion = { path = "../mozbase/rust/mozversion" }
+regex = { version="1.0", default-features = false, features = ["perf", "std"] }
+serde = "1.0"
+serde_derive = "1.0"
+serde_json = "1.0"
+serde_yaml = "0.8"
+uuid = { version = "0.8", features = ["v4"] }
+webdriver = { path = "../webdriver" }
+zip = { version = "0.4", default-features = false, features = ["deflate"] }
+
+[[bin]]
+name = "geckodriver"