summaryrefslogtreecommitdiffstats
path: root/testing/mozbase/rust/mozrunner/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mozbase/rust/mozrunner/Cargo.toml')
-rw-r--r--testing/mozbase/rust/mozrunner/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/mozbase/rust/mozrunner/Cargo.toml b/testing/mozbase/rust/mozrunner/Cargo.toml
new file mode 100644
index 0000000000..00beaee040
--- /dev/null
+++ b/testing/mozbase/rust/mozrunner/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "mozrunner"
+version = "0.12.1"
+authors = ["Mozilla"]
+description = "Reliable Firefox process management."
+repository = "https://hg.mozilla.org/mozilla-central/file/tip/testing/mozbase/rust/mozrunner"
+license = "MPL-2.0"
+edition = "2018"
+
+[dependencies]
+log = "0.4"
+mozprofile = { path = "../mozprofile", version = "0.7" }
+plist = "0.5"
+
+[target.'cfg(target_os = "windows")'.dependencies]
+winreg = "0.5"
+
+[target.'cfg(target_os = "macos")'.dependencies]
+dirs = "2"
+
+[[bin]]
+name = "firefox-default-path"