summaryrefslogtreecommitdiffstats
path: root/third_party/python/Click/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/Click/setup.py')
-rw-r--r--third_party/python/Click/setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/python/Click/setup.py b/third_party/python/Click/setup.py
new file mode 100644
index 0000000000..1c18dc7843
--- /dev/null
+++ b/third_party/python/Click/setup.py
@@ -0,0 +1,44 @@
+import io
+import re
+from setuptools import setup
+
+with io.open("README.rst", "rt", encoding="utf8") as f:
+ readme = f.read()
+
+with io.open("click/__init__.py", "rt", encoding="utf8") as f:
+ version = re.search(r"__version__ = \'(.*?)\'", f.read()).group(1)
+
+setup(
+ name="Click",
+ version=version,
+ url="https://palletsprojects.com/p/click/",
+ project_urls={
+ "Documentation": "https://click.palletsprojects.com/",
+ "Code": "https://github.com/pallets/click",
+ "Issue tracker": "https://github.com/pallets/click/issues",
+ },
+ license="BSD",
+ author="Armin Ronacher",
+ author_email="armin.ronacher@active-4.com",
+ maintainer="Pallets Team",
+ maintainer_email="contact@palletsprojects.com",
+ description="Composable command line interface toolkit",
+ long_description=readme,
+ packages=["click"],
+ include_package_data=True,
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ ],
+)