summaryrefslogtreecommitdiffstats
path: root/third_party/python/blessings/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/blessings/setup.py')
-rw-r--r--third_party/python/blessings/setup.py49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/python/blessings/setup.py b/third_party/python/blessings/setup.py
new file mode 100644
index 0000000000..01488fcdf4
--- /dev/null
+++ b/third_party/python/blessings/setup.py
@@ -0,0 +1,49 @@
+import sys
+
+# Prevent spurious errors during `python setup.py test`, a la
+# http://www.eby-sarna.com/pipermail/peak/2010-May/003357.html:
+try:
+ import multiprocessing
+except ImportError:
+ pass
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name='blessings',
+ version='1.7',
+ description='A thin, practical wrapper around terminal coloring, styling, and positioning',
+ long_description=open('README.rst').read(),
+ author='Erik Rose',
+ author_email='erikrose@grinchcentral.com',
+ license='MIT',
+ packages=find_packages(exclude=['ez_setup']),
+ install_requires=['six'],
+ tests_require=['nose'],
+ test_suite='nose.collector',
+ url='https://github.com/erikrose/blessings',
+ include_package_data=True,
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ classifiers=[
+ 'Intended Audience :: Developers',
+ 'Natural Language :: English',
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Environment :: Console :: Curses',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Software Development :: User Interfaces',
+ 'Topic :: Terminals'
+ ],
+ keywords=['terminal', 'tty', 'curses', 'ncurses', 'formatting', 'style', 'color', 'console'],
+)