summaryrefslogtreecommitdiffstats
path: root/third_party/python/coverage/MANIFEST.in
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/coverage/MANIFEST.in')
-rw-r--r--third_party/python/coverage/MANIFEST.in49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/python/coverage/MANIFEST.in b/third_party/python/coverage/MANIFEST.in
new file mode 100644
index 0000000000..75257c6068
--- /dev/null
+++ b/third_party/python/coverage/MANIFEST.in
@@ -0,0 +1,49 @@
+# Licensed under the Apache License: http://www.apache.org/licenses/LICENSE-2.0
+# For details: https://github.com/nedbat/coveragepy/blob/master/NOTICE.txt
+
+# MANIFEST.in file for coverage.py
+
+# This file includes everything needed to recreate the entire project, even
+# though many of these files are not installed by setup.py. Unpacking the
+# .tar.gz source distribution would give you everything needed to continue
+# developing the project. "pip install" will not install many of these files.
+
+include CONTRIBUTORS.txt
+include CHANGES.rst
+include LICENSE.txt
+include MANIFEST.in
+include Makefile
+include NOTICE.txt
+include README.rst
+include __main__.py
+include .travis.yml
+include appveyor.yml
+include howto.txt
+include igor.py
+include metacov.ini
+include pylintrc
+include setup.py
+include tox.ini
+include tox_wheels.ini
+include .editorconfig
+include .readthedocs.yml
+
+recursive-include ci *
+exclude ci/*.token
+
+recursive-include coverage/fullcoverage *.py
+recursive-include coverage/ctracer *.c *.h
+
+recursive-include doc *.py *.pip *.rst *.txt *.png
+recursive-include doc/_static *
+prune doc/_build
+prune doc/_spell
+
+recursive-include requirements *.pip
+
+recursive-include tests *.py *.tok
+recursive-include tests/gold *
+recursive-include tests js/* qunit/*
+prune tests/eggsrc/build
+
+global-exclude *.py[co]