summaryrefslogtreecommitdiffstats
path: root/third_party/python/distro/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/distro/setup.py')
-rw-r--r--third_party/python/distro/setup.py67
1 files changed, 67 insertions, 0 deletions
diff --git a/third_party/python/distro/setup.py b/third_party/python/distro/setup.py
new file mode 100644
index 0000000000..0657449267
--- /dev/null
+++ b/third_party/python/distro/setup.py
@@ -0,0 +1,67 @@
+# Copyright 2015,2016 Nir Cohen
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+import os
+import codecs
+from setuptools import setup
+
+# The following version is parsed by other parts of this package.
+# Don't change the format of the line, or the variable name.
+package_version = "1.4.0"
+
+here = os.path.abspath(os.path.dirname(__file__))
+
+
+def read(*parts):
+ # intentionally *not* adding an encoding option to open
+ return codecs.open(os.path.join(here, *parts), 'r').read()
+
+
+setup(
+ name='distro',
+ version=package_version,
+ url='https://github.com/nir0s/distro',
+ author='Nir Cohen',
+ author_email='nir36g@gmail.com',
+ license='Apache License, Version 2.0',
+ platforms='All',
+ description='Distro - an OS platform information API',
+ long_description=read('README.md'),
+ long_description_content_type='text/markdown',
+ py_modules=['distro'],
+ entry_points={
+ 'console_scripts': [
+ 'distro = distro:main',
+ ]
+ },
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: POSIX :: Linux',
+ 'Operating System :: POSIX :: BSD',
+ 'Operating System :: POSIX :: BSD :: FreeBSD',
+ 'Operating System :: POSIX :: BSD :: NetBSD',
+ 'Operating System :: POSIX :: BSD :: OpenBSD',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: System :: Operating System',
+ ]
+)