summaryrefslogtreecommitdiffstats
path: root/third_party/rust/Inflector/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/Inflector/Cargo.toml')
-rw-r--r--third_party/rust/Inflector/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/third_party/rust/Inflector/Cargo.toml b/third_party/rust/Inflector/Cargo.toml
new file mode 100644
index 0000000000..553f00f6de
--- /dev/null
+++ b/third_party/rust/Inflector/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "Inflector"
+version = "0.11.4"
+authors = ["Josh Teeter<joshteeter@gmail.com>"]
+include = ["**/*.rs", "Cargo.toml", "README.md"]
+description = "Adds String based inflections for Rust. Snake, kebab, camel, sentence, class, title and table cases as well as ordinalize, deordinalize, demodulize, foreign key, and pluralize/singularize are supported as both traits and pure functions acting on String types.\n"
+homepage = "https://github.com/whatisinternet/inflector"
+documentation = "https://docs.rs/Inflector"
+readme = "README.md"
+keywords = ["pluralize", "Inflector", "camel", "snake", "inflection"]
+categories = ["text-processing", "value-formatting"]
+license = "BSD-2-Clause"
+repository = "https://github.com/whatisinternet/inflector"
+
+[lib]
+name = "inflector"
+[dependencies.lazy_static]
+version = "1.2.0"
+optional = true
+
+[dependencies.regex]
+version = "1.1"
+optional = true
+
+[features]
+default = ["heavyweight"]
+heavyweight = ["regex", "lazy_static"]
+unstable = []
+[badges.travis-ci]
+repository = "whatisinternet/Inflector"