summaryrefslogtreecommitdiffstats
path: root/third_party/rust/authenticator/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/authenticator/Cargo.toml')
-rw-r--r--third_party/rust/authenticator/Cargo.toml99
1 files changed, 99 insertions, 0 deletions
diff --git a/third_party/rust/authenticator/Cargo.toml b/third_party/rust/authenticator/Cargo.toml
new file mode 100644
index 0000000000..57d24bd66b
--- /dev/null
+++ b/third_party/rust/authenticator/Cargo.toml
@@ -0,0 +1,99 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "authenticator"
+version = "0.3.1"
+authors = ["J.C. Jones <jc@mozilla.com>", "Tim Taubert <ttaubert@mozilla.com>", "Kyle Machulis <kyle@nonpolynomial.com>"]
+description = "Library for interacting with CTAP1/2 security keys for Web Authentication. Used by Firefox."
+keywords = ["ctap2", "u2f", "fido", "webauthn"]
+categories = ["cryptography", "hardware-support", "os"]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/authenticator-rs/"
+[dependencies.base64]
+version = "^0.10"
+optional = true
+
+[dependencies.bitflags]
+version = "1.0"
+
+[dependencies.bytes]
+version = "0.5"
+features = ["serde"]
+optional = true
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.rand]
+version = "0.7"
+
+[dependencies.runloop]
+version = "0.1.0"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.serde_json]
+version = "1.0"
+optional = true
+
+[dependencies.tokio]
+version = "0.2"
+features = ["macros"]
+optional = true
+
+[dependencies.warp]
+version = "0.2.4"
+optional = true
+[dev-dependencies.assert_matches]
+version = "1.2"
+
+[dev-dependencies.base64]
+version = "^0.10"
+
+[dev-dependencies.env_logger]
+version = "^0.6"
+
+[dev-dependencies.getopts]
+version = "^0.2"
+
+[dev-dependencies.sha2]
+version = "^0.8.2"
+[build-dependencies.bindgen]
+version = "^0.51"
+optional = true
+
+[features]
+binding-recompile = ["bindgen"]
+webdriver = ["base64", "bytes", "warp", "tokio", "serde", "serde_json"]
+[target."cfg(target_os = \"freebsd\")".dependencies.devd-rs]
+version = "0.3"
+[target."cfg(target_os = \"linux\")".dependencies.libudev]
+version = "^0.2"
+[target."cfg(target_os = \"macos\")".dependencies.core-foundation]
+version = "0.9"
+[target."cfg(target_os = \"windows\")".dependencies.winapi]
+version = "^0.3"
+features = ["handleapi", "hidclass", "hidpi", "hidusage", "setupapi"]
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+branch = "master"
+repository = "mozilla/authenticator-rs"