summaryrefslogtreecommitdiffstats
path: root/third_party/rust/base64/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/base64/Cargo.toml')
-rw-r--r--third_party/rust/base64/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/rust/base64/Cargo.toml b/third_party/rust/base64/Cargo.toml
new file mode 100644
index 0000000000..c92b54a3e3
--- /dev/null
+++ b/third_party/rust/base64/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "base64"
+version = "0.12.0"
+authors = ["Alice Maz <alice@alicemaz.com>", "Marshall Pierce <marshall@mpierce.org>"]
+description = "encodes and decodes base64 as bytes or utf8"
+documentation = "https://docs.rs/base64"
+readme = "README.md"
+keywords = ["base64", "utf8", "encode", "decode", "no_std"]
+categories = ["encoding"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/marshallpierce/rust-base64"
+[profile.bench]
+debug = true
+
+[[bench]]
+name = "benchmarks"
+harness = false
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.doc-comment]
+version = "0.3"
+
+[dev-dependencies.rand]
+version = "0.6.1"
+
+[features]
+alloc = []
+default = ["std"]
+std = []