summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cache-padded/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/cache-padded/Cargo.toml')
-rw-r--r--third_party/rust/cache-padded/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/rust/cache-padded/Cargo.toml b/third_party/rust/cache-padded/Cargo.toml
new file mode 100644
index 0000000000..d9464196fa
--- /dev/null
+++ b/third_party/rust/cache-padded/Cargo.toml
@@ -0,0 +1,25 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "cache-padded"
+version = "1.1.1"
+authors = ["Stjepan Glavina <stjepang@gmail.com>"]
+description = "Prevent false sharing by padding and aligning to the length of a cache line"
+homepage = "https://github.com/stjepang/cache-padded"
+documentation = "https://docs.rs/cache-padded"
+readme = "README.md"
+keywords = ["cache", "padding", "lock-free", "atomic"]
+categories = ["concurrency", "no-std"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/stjepang/cache-padded"