summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cast/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/cast/Cargo.toml')
-rw-r--r--third_party/rust/cast/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/third_party/rust/cast/Cargo.toml b/third_party/rust/cast/Cargo.toml
new file mode 100644
index 0000000000..3534ad53a5
--- /dev/null
+++ b/third_party/rust/cast/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+authors = ["Jorge Aparicio <jorge@japaric.io>"]
+description = "Ergonomic, checked cast functions for primitive types"
+documentation = "https://docs.rs/cast"
+keywords = ["checked", "cast", "primitive", "integer", "float"]
+license = "MIT OR Apache-2.0"
+name = "cast"
+repository = "https://github.com/japaric/cast.rs"
+version = "0.2.2"
+
+[features]
+# Assume we should use `std` unless asked to do otherwise.
+default = ["std"]
+# Enable this to get a std::error::Error impl for convenient use with other
+# libraries.
+std = []
+# Enable this for i128/u128 support
+x128 = []
+
+[dev-dependencies]
+quickcheck = "0.4.1"