summaryrefslogtreecommitdiffstats
path: root/third_party/rust/chrono/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/chrono/Cargo.toml')
-rw-r--r--third_party/rust/chrono/Cargo.toml92
1 files changed, 92 insertions, 0 deletions
diff --git a/third_party/rust/chrono/Cargo.toml b/third_party/rust/chrono/Cargo.toml
new file mode 100644
index 0000000000..5534ad2089
--- /dev/null
+++ b/third_party/rust/chrono/Cargo.toml
@@ -0,0 +1,92 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "chrono"
+version = "0.4.10"
+authors = ["Kang Seonghoon <public+rust@mearie.org>", "Brandon W Maister <quodlibetor@gmail.com>"]
+exclude = ["/ci/*", "/.travis.yml", "/appveyor.yml", "/Makefile"]
+description = "Date and time library for Rust"
+homepage = "https://github.com/chronotope/chrono"
+documentation = "https://docs.rs/chrono/"
+readme = "README.md"
+keywords = ["date", "time", "calendar"]
+categories = ["date-and-time"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/chronotope/chrono"
+[package.metadata.docs.rs]
+all-features = true
+
+[package.metadata.playground]
+all-features = true
+
+[lib]
+name = "chrono"
+[dependencies.num-integer]
+version = "0.1.36"
+default-features = false
+
+[dependencies.num-traits]
+version = "0.2"
+default-features = false
+
+[dependencies.rustc-serialize]
+version = "0.3.20"
+optional = true
+
+[dependencies.serde]
+version = "1.0.99"
+optional = true
+default-features = false
+
+[dependencies.time]
+version = "0.1.39"
+optional = true
+[dev-dependencies.bincode]
+version = "0.8.0"
+
+[dev-dependencies.doc-comment]
+version = "0.3"
+
+[dev-dependencies.num-iter]
+version = "0.1.35"
+default-features = false
+
+[dev-dependencies.serde_derive]
+version = "1"
+default-features = false
+
+[dev-dependencies.serde_json]
+version = "1"
+default-features = false
+
+[features]
+alloc = []
+bench = ["std"]
+clock = ["time", "std"]
+default = ["clock", "std"]
+std = []
+wasmbind = ["wasm-bindgen", "js-sys"]
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dependencies.js-sys]
+version = "0.3"
+optional = true
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dependencies.wasm-bindgen]
+version = "0.2"
+optional = true
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dev-dependencies.wasm-bindgen-test]
+version = "0.2"
+[badges.appveyor]
+repository = "chronotope/chrono"
+
+[badges.travis-ci]
+repository = "chronotope/chrono"