summaryrefslogtreecommitdiffstats
path: root/third_party/rust/const_fn/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/const_fn/Cargo.toml')
-rw-r--r--third_party/rust/const_fn/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/third_party/rust/const_fn/Cargo.toml b/third_party/rust/const_fn/Cargo.toml
new file mode 100644
index 0000000000..6017735bc2
--- /dev/null
+++ b/third_party/rust/const_fn/Cargo.toml
@@ -0,0 +1,30 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "const_fn"
+version = "0.4.5"
+authors = ["Taiki Endo <te316e89@gmail.com>"]
+exclude = ["/.github", "/scripts"]
+description = "An attribute for easy generation of const functions with conditional compilations.\n"
+documentation = "https://docs.rs/const_fn"
+readme = "README.md"
+keywords = ["macros", "attribute", "const", "static"]
+categories = ["rust-patterns", "no-std"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/taiki-e/const_fn"
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+proc-macro = true