summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cranelift-wasm/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/cranelift-wasm/Cargo.toml')
-rw-r--r--third_party/rust/cranelift-wasm/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/cranelift-wasm/Cargo.toml b/third_party/rust/cranelift-wasm/Cargo.toml
new file mode 100644
index 0000000000..d8bd9d2c44
--- /dev/null
+++ b/third_party/rust/cranelift-wasm/Cargo.toml
@@ -0,0 +1,39 @@
+[package]
+name = "cranelift-wasm"
+version = "0.68.0"
+authors = ["The Cranelift Project Developers"]
+description = "Translator from WebAssembly to Cranelift IR"
+documentation = "https://docs.rs/cranelift-wasm"
+repository = "https://github.com/bytecodealliance/wasmtime"
+license = "Apache-2.0 WITH LLVM-exception"
+categories = ["no-std", "wasm"]
+readme = "README.md"
+keywords = ["webassembly", "wasm"]
+edition = "2018"
+
+[dependencies]
+wasmparser = { git = "https://github.com/mozilla-spidermonkey/wasm-tools", rev = "1b7763faa484e62752538b78e7a69883f4faceee", default-features = false }
+cranelift-codegen = { path = "../codegen", version = "0.68.0", default-features = false }
+cranelift-entity = { path = "../entity", version = "0.68.0" }
+cranelift-frontend = { path = "../frontend", version = "0.68.0", default-features = false }
+hashbrown = { version = "0.9.1", optional = true }
+itertools = "0.9.0"
+log = { version = "0.4.6", default-features = false }
+serde = { version = "1.0.94", features = ["derive"], optional = true }
+smallvec = "1.0.0"
+thiserror = "1.0.4"
+
+[dev-dependencies]
+wat = "1.0.23"
+target-lexicon = "0.11"
+# Enable the riscv feature for cranelift-codegen, as some tests require it
+cranelift-codegen = { path = "../codegen", version = "0.68.0", default-features = false, features = ["riscv"] }
+
+[features]
+default = ["std"]
+std = ["cranelift-codegen/std", "cranelift-frontend/std"]
+core = ["hashbrown", "cranelift-codegen/core", "cranelift-frontend/core"]
+enable-serde = ["serde"]
+
+[badges]
+maintenance = { status = "experimental" }