summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cssparser/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/cssparser/Cargo.toml')
-rw-r--r--third_party/rust/cssparser/Cargo.toml68
1 files changed, 68 insertions, 0 deletions
diff --git a/third_party/rust/cssparser/Cargo.toml b/third_party/rust/cssparser/Cargo.toml
new file mode 100644
index 0000000000..2275106788
--- /dev/null
+++ b/third_party/rust/cssparser/Cargo.toml
@@ -0,0 +1,68 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "cssparser"
+version = "0.28.1"
+authors = ["Simon Sapin <simon.sapin@exyr.org>"]
+build = "build.rs"
+exclude = ["src/css-parsing-tests/**", "src/big-data-url.css"]
+description = "Rust implementation of CSS Syntax Level 3"
+documentation = "https://docs.rs/cssparser/"
+readme = "README.md"
+keywords = ["css", "syntax", "parser"]
+license = "MPL-2.0"
+repository = "https://github.com/servo/rust-cssparser"
+[dependencies.cssparser-macros]
+version = "0.6"
+
+[dependencies.dtoa-short]
+version = "0.3"
+
+[dependencies.itoa]
+version = "0.4"
+
+[dependencies.matches]
+version = "0.1"
+
+[dependencies.phf]
+version = "0.8"
+features = ["macros"]
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dependencies.smallvec]
+version = "1.0"
+[dev-dependencies.difference]
+version = "2.0"
+
+[dev-dependencies.encoding_rs]
+version = "0.8"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+[build-dependencies.proc-macro2]
+version = "1"
+
+[build-dependencies.quote]
+version = "1"
+
+[build-dependencies.syn]
+version = "1"
+features = ["extra-traits", "fold", "full"]
+
+[features]
+bench = []
+dummy_match_byte = []