summaryrefslogtreecommitdiffstats
path: root/third_party/rust/deflate/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/deflate/Cargo.toml')
-rw-r--r--third_party/rust/deflate/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/rust/deflate/Cargo.toml b/third_party/rust/deflate/Cargo.toml
new file mode 100644
index 0000000000..0c970cb1d0
--- /dev/null
+++ b/third_party/rust/deflate/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "deflate"
+version = "0.7.19"
+authors = ["oyvindln <oyvindln@users.noreply.github.com>"]
+description = "A DEFLATE, zlib and gzip encoder written in rust.\n"
+homepage = "https://github.com/oyvindln/deflate-rs"
+documentation = "https://docs.rs/deflate/"
+readme = "README.md"
+keywords = ["flate", "deflate", "zlib", "compression", "gzip"]
+categories = ["compression"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/oyvindln/deflate-rs"
+[package.metadata.docs.rs]
+features = ["gzip"]
+[dependencies.adler32]
+version = "1.0.2"
+
+[dependencies.byteorder]
+version = "1.0.0"
+
+[dependencies.gzip-header]
+version = "0.2"
+optional = true
+[dev-dependencies.flate2]
+version = "1.0.0"
+
+[features]
+benchmarks = []
+gzip = ["gzip-header"]
+[badges.travis-ci]
+branch = "dev"
+repository = "oyvindln/deflate-rs"